Unable to specify IP address for Plesk: at least one IP address must be selected

Created:

2016-11-16 12:57:40 UTC

Modified:

2017-08-16 16:34:27 UTC

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Unable to specify IP address for Plesk: at least one IP address must be selected

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Symptoms

Unable to specify IP address for Plesk. The error is:

At least one IP address must be selected

The /var/log/plesk/panel.log file shows the following error messages:

ERR [panel] [57978dd697d41] Result of interface implementation call: failure: Method arguments cannot be decoded

Cause

Power User view is enabled on a server, and Plesk administrator does not have any subscription while all IP addresses are dedicated.

So when Power User view is ON, Plesk Administrator can not edit IP addresses and create subscriptions.

Resolution

It is required to switch to the Service Provider view so that all Plesk operations are available to Plesk admin.

  1. Use the following command to switch to the Service Provider view:

    /usr/local/psa/bin/poweruser --off
  2. Log out and log in to Plesk again

Note that Web Admin and Web App editions do not support Service Provider view. Only Web Pro and Web Host editions support it. If Web Admin or Web App licenses are used, visit the following article for a solution:

#213924925 Unable to login to Plesk after installing a new license: start up screen appears that suggests to create the first webspace

Additional information

To learn more about Plesk 12.5 editions, visit:

213903085 Plesk 12 available editions and difference between them

More details about differences between Service Provider view and Power User view are available in Plesk Administrator Guide .

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