Horde webmail shows 500 internal server error on PHP 5.2

Created:

2016-11-16 12:57:39 UTC

Modified:

2017-04-24 11:14:49 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Horde webmail shows 500 internal server error on PHP 5.2

Applicable to:

  • Plesk 11.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Symptoms

Horde Webmail shows 500 internal server error in the Apache web server log file /var/log/httpd/error_log

[warn] [client 91.204.25.4] mod_fcgid: stderr: PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required '__DIR__/lib/Application.php' (include_path='.:') in /usr/share/psa-horde/index.php on line 16
[warn] [client 91.204.25.4] mod_fcgid: stderr: PHP Notice: Use of undefined constant __DIR__ - assumed '__DIR__' in /usr/share/psa-horde/index.php on line 16

Cause

Horde 5.x requires PHP 5.3.0 or above.
PHP version installed on the server is incompatible.

Resolution

Consider updating the PHP version installed on the server to the required one.

Have more questions? Submit a request
Please sign in to leave a comment.