AWStats statistics not updated for all domains

Created:

2016-11-16 12:56:32 UTC

Modified:

2017-04-24 11:03:25 UTC

0

Was this article helpful?


Have more questions?

Submit a request

AWStats statistics not updated for all domains

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 9.3.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 10.3 for Linux

Symptoms

  1. AWStats statistics are not updated on the plesk-stat/webstat page. The issue exists for ALL domains that use AWStats.

  2. If enable debug output for the statistics utility:

    # export STATISTICS_DEBUG=yes

, and run statistics calculation the following error occurs:

    # /usr/local/psa/admin/bin/statistics --calculate-one --domain-name domain.tld
Main HTML page is 'awstats.example.com-http.html'.  sh: /srv/www/cgi-bin/awstats.pl: No such file or directory  Build main page: "/srv/www/cgi-bin/awstats/awstats.pl" -config=example.com-https -staticlinks -configdir=/usr/local/psa/etc/awstats -month=10 -year=2012 -output  Build errors404 page: "/srv/www/cgi-bin/awstats/awstats.pl" -config=example.com-https -staticlinks -configdir=/usr/local/psa/etc/awstats -month=10 -year=2012 -output=errors404  21 files built.

Cause

Most likely AWSTATS_BIN_D value is wrong in /etc/psa/psa.conf configuration file.

Resolution

Change the AWSTATS_BIN_D value from /srv/www/cgi-bin to /srv/www/cgi-bin/awstats in /etc/psa/psa.conf configuration file.

Have more questions? Submit a request
Please sign in to leave a comment.