Email auto-responder does not work for some domains in Plesk

Follow

Comments

4 comments

  • Avatar
    Miha Gregorš

    Hi,

    we have a situation that auto-reply does not work at all on whole server for none of the domains. After enable auto-reply/responder for some email address then after sending a test email, nothing happened, no reply email is send to sender.

    Here are some error logs from Postfix.

    Jun 22 12:56:17 vps autoresponder[8763]: Starting the autoresponder filter...
    Jun 22 12:56:17 vps autoresponder[8763]: Starting the autoresponder filter...
    Jun 22 13:03:13 vps postfix-local[10529]: Error during 'autoresponder' handler
    Jun 22 13:03:13 vps postfix-local[10529]: Error during 'autoresponder' handler
    Jun 22 13:04:24 vps postfix-local[10719]: Error during 'autoresponder' handler
    Jun 22 13:04:24 vps postfix-local[10719]: Error during 'autoresponder' handler
    Jun 22 13:05:33 vps postfix-local[10870]: Error during 'autoresponder' handler
    Jun 22 13:05:33 vps postfix-local[10870]: Error during 'autoresponder' handler
    Jun 22 13:21:24 vps autoresponder[13624]: Starting the autoresponder filter...
    Jun 22 13:21:24 vps autoresponder[13624]: Starting the autoresponder filter...
    Jun 22 13:29:39 vps autoresponder[15005]: Starting the autoresponder filter...
    Jun 22 13:29:39 vps autoresponder[15005]: Starting the autoresponder filter...
    Jun 22 13:37:29 vps autoresponder[16289]: Some args not defined. Use /usr/local/psa/handlers/hooks/autoresponder <CONTEXT> <FROM> <TO>
    Jun 22 13:37:29 vps autoresponder[16289]: Some args not defined. Use /usr/local/psa/handlers/hooks/autoresponder <CONTEXT> <FROM> <TO>
    Jun 22 13:37:29 vps autoresponder[16289]: Unable to intialize autoresponder mail handler
    Jun 22 13:37:29 vps autoresponder[16289]: Unable to intialize autoresponder mail handler
    Jun 22 13:50:21 vps autoresponder[18574]: Starting the autoresponder filter...
    Jun 22 13:50:21 vps autoresponder[18574]: Starting the autoresponder filter...
    Jun 22 13:52:01 vps autoresponder[18909]: Starting the autoresponder filter...
    Jun 22 13:52:01 vps autoresponder[18909]: Starting the autoresponder filter...
    Jun 22 14:16:57 vps autoresponder[14690]: Starting the autoresponder filter...
    Jun 22 14:16:57 vps autoresponder[14690]: Starting the autoresponder filter...

    Regards, Miha

     

    ...

  • Avatar
    Miha Gregorš

    Hi,

    I forgot to paste this information :)

    OS CentOS Linux 7.5.1804 (Core)
    Product

    Plesk Onyx
    Version 17.8.11 Update #11, last updated on June 21, 2018 05:56 AM

     

    ...

  • Avatar
    Miha Gregorš

    Hi,

    we solve the problem. We check postfix configuration with command: postfix check

    Result:
    [root@vps]~>postfix check
    postfix/postfix-script: warning: /usr/lib/sendmail and /usr/sbin/sendmail differ postfix/postfix-script: warning: Replace one by a symbolic link to the other

    Solution:
    [root@vps]~>ln -s /etc/alternatives/mta /usr/sbin/sendmail

    Now auto-reply works.

    Regards, Miha

  • Avatar
    Ivan Postnikov

    Hello @Miha,

    Glad that the issue is resolved. Thank you for sharing the solution.

Please sign in to leave a comment.

Have more questions? Submit a request