Auto-reply does not work

Created:

2016-11-16 12:56:24 UTC

Modified:

2017-04-24 11:33:18 UTC

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Auto-reply does not work

Applicable to:

  • Plesk 11.0 for Windows
  • Plesk 11.0 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Symptoms

Email auto-responder does not work for some particular domain.

Cause

MX DNS records for this domain point to a 3rdparty mail server.

Resolution

To diagnose the issue you may follow these steps:

  1. Check current mail server record for domain.com:

    [root@server ~]# nslookup -type=MX domain.com 8.8.8.8
    Server: 8.8.8.8
    Address: 8.8.8.8#53
    Non-authoritative answer:
    domain.com mail exchanger = 10 server2.com.
  2. Check IP address of "server2.com":

    [root@pvclinux64 ~]# nslookup server2.com 8.8.8.8
    Server: 8.8.8.8
    Address: 8.8.8.8#53
    Non-authoritative answer:
    Name: server2.com
    Address: 192.168.50.2
  3. Check whether IP address 192.168.50.2 is present on the Plesk server:

    ip a|grep 192.168.50.2
  4. To enable the autoresponder functionality you may correct MX records for the domain in DNS settings in Panel.

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