When I try to access Parallels Plesk Panel, I’m redirected to incorrect URL

Refers to:

  • Plesk 11.5 for Windows
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:54:52 UTC

Modified:

2016-12-21 19:31:23 UTC

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When I try to access Parallels Plesk Panel, I’m redirected to incorrect URL

Symptoms

•    After installation, when you try to go to https://your-domain-name:8443 to log in to Plesk, you are redirected to an incorrect URL: https://incorrect-url:11444/relay

•    After running the postinstall wizard and trying to log out, you are redirected to an incorrect URL: https://incorrect-url:11444/relay

•    When you try to log in to Plesk the second time (after the postinstall wizard is run), you are redirected to an incorrect URL: https://incorrect-url:11444/relay

Cause

Custom & Business Manager and SSO are configured to work with an incorrect URL.

Resolution

  1. Change the server hostname to a valid one – follow the instructions given in this KB article How can I change server hostname for Parallels Plesk Panel 10 integrated with Customer & Business Manager? if you are using the local Customer & Business Manager .

  2. Check SSO settings:

/usr/local/psa/bin/sso -g

If hostname is not correct, update hostname with server_pref utility:

    /usr/local/psa/bin/server_pref --update -hostname <relevant_correct_hostname>
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