Sitebuilder reports that it cannot configure publishing settings for my site. Ho do I resolve the problem?

Refers to:

  • Plesk Sitebuilder 4.5 for Linux

Created:

2016-11-16 12:54:49 UTC

Modified:

2016-12-21 19:31:15 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Sitebuilder reports that it cannot configure publishing settings for my site. Ho do I resolve the problem?

Symptoms

I receive errors when try to configure publishing settings for my site. The following error occurs then acess

Sitebuilder > Sites > **SITE** > Publishing Settings
--->8---
Error: Site publishing settings cannot be changed. There are no publishing modes available.
---8<---

And the following error is shown on the Publish page in Sitebuilder Wizard:

--->8---
Publishing is not available.
The defined publishing settings are not allowed by your service plan. Please contact the server administrator.
---8<---

Resolution

You should reconfigure user's plan to resolve the problem. You may do that as follows.

  1. Find the site owner. For that you should login to Sitebuilder control panel as administrator and change to the Sites page. The site owner is specified in the Owner field opposite the site name.
  2. Find owner of the site owner. Change to page Users and find the site owner – owner of this user is shown under the Owner tab. If owner is admin, then you may go to next step and proceed with plan configuration; if owner is another reseller, then you should continue searching for root owner.
  3. Find plan assigned to the site owner. The plan is shown and editable through control panel of root owner. In Sitebuilder control panel change to the Users page and click the site owner's name. The plan is shown in the Plan column.
  4. Add Publishing modes to the plan. In Sitebuilder control panel change to the User page and enter Plans tool. Among the plans shown select the plan name found earlier and change to the Publishing Settings bookmark. In the Publishing modes paragraph select FTP, VPS or XCopy modes.

Note : plan assigned to the site owner may not be shown on the Plans subpage. That means that the plan was created by reseller that owns the site owner. In this case you should login to Sitebuilder control panel as reseller and reconfigure the plan the same way.

For complicated ownership:

The site is owned by site owner "SITE_OWNER":

Sitebuilder > Sites
--->8---
Site name Owner
SITE_ALIAS SITE_OWNER
---8<---

which belongs to reseller "RESELLER1":

Sitebuilder > Users
--->8---
User name Role Owner
SITE_OWNER Site Owner RESELLER1
---8<---

which belongs to reseller "RESELLER2":

Sitebuilder > Users
--->8---
User name Role Owner
RESELLER1 Site Owner RESELLER2
---8<---

It's by design that plan of site owner "SITE_OWNER" is show and editable in CP of reseller "RESELLER1".

Administrator is not able to login to CP of reseller "RESELLER1" usual way: only login to CP of major reseller "RESELLER2" is possible:

Sitebuilder > Users > RESELLER2 > Log under this user account

In this cause administrator may reconfigure the plan settings in the Sitebuilder database manually:

# mysql sitebuilder3
...
mysql> select * from site where alias='SITE_ALIAS'\\G
*************************** 1. row ***************************
id: 2473
dir_name: a8571f2e893b9d7d6b2178520f16d309
site_id: a8571f2e893b9d7d6b2178520f16d309
alias: SITE_ALIAS
password: a21723a4b6984cb40d6fc9bad1a239f7
creation_date: 2008-09-13T13:41:31+10:00
user_id: 1249

mysql> select plan_id from user where id=1249;
+---------+
| plan_id |
+---------+
| 15 |
+---------+
1 row in set (0.00 sec)

mysql>

No publishing modes are configured in the plan:

mysql> select * from plan_publish_mode where plan_id=15;
Empty set (0.00 sec)

mysql>

I created the missing records:

mysql> insert into plan_publish_mode (plan_id,publish_mode_id) values (15,1);
mysql> insert into plan_publish_mode (plan_id,publish_mode_id) values (15,2);
mysql> insert into plan_publish_mode (plan_id,publish_mode_id) values (15,3);
Have more questions? Submit a request
Please sign in to leave a comment.