"Backup Manager" page in Parallels Plesk Panel for Debian/Ubuntu does not open. Plesk utilities are faiing with Segmentation fault error 4.

Refers to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 10.0.0 for Linux

Created:

2016-11-16 12:54:48 UTC

Modified:

2016-12-21 19:31:12 UTC

0

Was this article helpful?


Have more questions?

Submit a request

"Backup Manager" page in Parallels Plesk Panel for Debian/Ubuntu does not open. Plesk utilities are faiing with Segmentation fault error 4.

Symptoms

  1. The following error appears when attempting to open the Backup Manager page:

    --->8---
    ERROR: PleskPMMResponseException

    Up Level
    Failed to parse response. Reason: Failed to read data from stream Process output:

    0: PMMConnector.php:635
    PMMConnector->getResponse(object of type StreamXMLReader)
    1: PMMConnector.php:509
    PMMConnector->getConfigParameters()
    2: BackupServerWideSettings.php:44
    BackupServerWideSettings->init()
    3: BackupServerWideSettings.php:19
    BackupServerWideSettings->__construct()
    4: server.backup.properties.php:28
    plesk__server__backup__properties->accessItem(string 'GET', NULL null)
    5: UIPointer.php:595
    UIPointer->access(string 'GET')
    6: plesk.php:45
    ---8<---
  2. Also, the Plesk utility tomcatmng fails with the Segmentation fault:

    # /usr/local/psa/admin/sbin/tomcatmng --is-configured
    Segmentation fault
  3. The following errors appear in the system log file:

    /var/log/messages
    ---8<---
    Nov 30 05:34:58 plesk kernel: [5308000.594477] tomcatmng[1977]: segfault at 300001c4f rip 7f61f8f2c306 rsp 7fff019adf18 error 4
    Nov 30 05:36:12 plesk kernel: [5308074.716175] tomcatmng[2336]: segfault at 300001c4f rip 7fab48b84306 rsp 7fff51605b68 error 4
    Nov 30 05:37:31 plesk kernel: [5308154.035933] pmmcli[2568]: segfault at 400001c4f rip 7f5fd935b306 rsp 7fffe20ff7d8 error 4
    Nov 30 05:38:33 plesk kernel: [5308215.301709] pmmcli[2585]: segfault at 400001c4f rip 7f0ab5906306 rsp 7fffbe6aad78 error 4
    --->8---
  4. (For CentOS) - not possible to install any package with yum:

    yum install strace
    ...
    Segmentation fault

Cause

The file /usr/lib/libz.so.1 is linked to a custom library:

For Debian:

# ls -la /usr/lib/libz.so.*
lrwxrwxrwx 1 root root 15 Nov 30 08:35 /usr/lib/libz.so.1 -> libz.so.1.2.5

# dpkg -S /usr/lib/libz.so.1.2.5
dpkg: /usr/lib/libz.so.1.2.5 not found.

For CentOS:

# ls -la /usr/lib/libz.so.*
lrwxrwxrwx 1 root root 13 Feb 27 19:14 /usr/lib/libz.so.1 -> libz.so.1.2.5
-rwxr-xr-x 1 root root 75028 Jan 9 2007 /usr/lib/libz.so.1.2.3
-rwxr-xr-x 1 root root 109359 Mar 22 2013 /usr/lib/libz.so.1.2.5

# rpm -qf /usr/lib/libz.so.1
zlib-1.2.3-3

# rpm -V zlib-1.2.3-3
....L... /usr/lib/libz.so.1

# rpm -qf /usr/lib/libz.so.1.2.5
file /usr/lib/libz.so.1.2.5 is not owned by any package

Resolution

Remove the invalid link and create a valid link to the file, provided by the zlib1g package:

# dpkg -L zlib1g
/.
/usr
/usr/lib
/usr/lib/libz.so.1.2.3.3
..
# cd /usr/lib/
# unlink libz.so.1
# ln -s /usr/lib/libz.so.1.2.3.3 libz.so.1
Have more questions? Submit a request
Please sign in to leave a comment.