Site Families cannot be selected in Wizard

Created:

2016-11-16 12:54:42 UTC

Modified:

2017-04-24 12:07:54 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Site Families cannot be selected in Wizard

Applicable to:

  • Plesk Sitebuilder 4.5 for Linux

Symptoms

Client cannot select site families " Create your Blog " and " Create your photogallery " on page " Start " in Wizard on creation new site.

The site families are visible, but they cannot be selected:

Cause

Broken configuration in the database. Id of template categories "blog" and "photogallery" have been changed:

mysql> select id, template_category_id, code from site_familia;
+----+----------------------+--------------+
| id | template_category_id | code |
+----+----------------------+--------------+
| 1 | 0 | generic |
| 2 | 2 | blog |
| 3 | 3 | photogallery |
+----+----------------------+--------------+
3 rows in set (0.00 sec)

mysql> select * from template_category where id in (2,3);
Empty set (0.00 sec)

mysql>

The categories have another IDs:

mysql> select * from template_category where name in ('Blog','Art and Photography');
+-----+---------------------+
| id | name |
+-----+---------------------+
| 94 | Blog |
| 104 | Art and Photography |
+-----+---------------------+
2 rows in set (0.00 sec)

mysql>

Resolution

Backup database of Parallels Plesk Sitebuilder:

~# mysqldump -u<MYSQL_USER> -p<MYSQL_PASSWORD> --skip-extended-insert sitebuilder3 > sitebuilder3.dump.`date +%F.%s`.sql

Change template_category_id in table site_familia:

mysql> update site_familia set template_category_id=94 where template_category_id=2;
mysql> update site_familia set template_category_id=104 where template_category_id=3;
Have more questions? Submit a request
Please sign in to leave a comment.