Emails are not being received by MailEnable: "denied access"

Refers to:

  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Created:

2016-11-16 12:54:34 UTC

Modified:

2017-01-18 21:13:35 UTC

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Emails are not being received by MailEnable: "denied access"

Symptoms

  1. Accessing the MailEnable SMTP service produces an error that the connecting IP address has been "denied access".

    Example error:

    530 mail.mailenable.com.au ESMTP MailEnable Service, Version: 0--1.1 denied access at 09/06/05 17:04:25
    Connection to host lost.
  2. Connection from outside to server IP address and 25 port does not work:

    telnet 192.168.0.25
    220 mail.mailenable.com.au ESMTP MailEnable Service, Version: 0--1.1 denied access at 09/26/13 21:53:27
    Connection lost

The same error can be found in MailEnable Management > Servers > localhost > Services and Connectors > SMTP > Logs > Activity > SMTP-Activity-xxx.log .

Cause

The IP address of the inbound connection has been denied access in the SMTP Access Control properties of the MailEnable Administration Program or has been automatically banned because of too many subsequent invalid commands.

Resolution

  1. Navigate within the Administration console to the following location: Servers>localhost>connectors>SMTP , right click on SMTP and select Properties in the menu.

  2. Next navigate to the Inbound tab and click on Access control .

  3. Ensure that the Access control option is set to granted access and that the IP address of the incoming connection is not present within the Except those listed below window.

Information

The incoming IP address can automatically be added to the inbound Access control list if the SMTP security connection dropping option is enabled. The SMTP service will drop the connection when the failed number of commands or recipients is exceeded and add the IP address to the inbound Access control list.

MailEnable

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