Plesk shows: ERROR: ERROR: Class Limits_Limit_Base contains 1 abstract method

Refers to:

  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Created:

2016-11-16 12:54:25 UTC

Modified:

2016-12-21 19:30:16 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk shows: ERROR: ERROR: Class Limits_Limit_Base contains 1 abstract method

Symptoms

Plesk shows following error:

ERROR: Class Limits_Limit_Base contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (Limits_Limit_Interface::setBackendSubscriptionLimitValue) (Base.php:353)

Cause

Micro updates were not successfully installed.

Resolution

Reinstall micro updates.

MS Windows:

 "%plesk_dir%\\admin\\bin\\ai.exe" --select-product-id panel --select-release-current --reinstall-patch --install-component base

Linux:

    # /usr/local/psa/admin/sbin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base
Have more questions? Submit a request
Please sign in to leave a comment.