Mailing list not working in Plesk: "Name or service not known"

Created:

2016-11-16 12:53:27 UTC

Modified:

2017-08-16 16:35:54 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Mailing list not working in Plesk: "Name or service not known"

Applicable to:

  • Plesk 10.x for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux

Symptoms

Mailing list not working. It is enabled and list is successfully created. However mails are not getting delivered to the list.

The following errors may be found in /var/log/mailman/smtp-failure :

Feb 21 16:39:30 2014 (17454) delivery to user@external.tld failed with code -1: [Errno -2] Name or service not known
Feb 21 16:42:33 2014 (13709) delivery to user@external.tld failed with code -1: [Errno -2] Name or service not known
Feb 21 16:57:44 2014 (13709) delivery to user@external.tld failed with code -1: [Errno -2] Name or service not known
Feb 21 17:05:39 2014 (13709) delivery to user@external.tld failed with code -1: [Errno -2] Name or service not known

Cause

Hostname is configured improperly in /etc/hosts file: server alias name is placed before server FQDN in entry for network interface, or an entry for network interface is missing at all.

The correct format is as follows:

127.0.0.1 localhost.localdomain localhost
<server_IP> <server_FQDN> <server_alias_name>

Resolution

  1. Check server's FQDN:

    # hostname -f
    mailserver.somemail.tld
  2. Update hostname in '/etc/hosts' file:

    127.0.0.1 localhost.localdomain localhost
    1.2.3.4 mailserver.somemail.tld mailserver
  3. Check DEFAULT_URL_HOST and DEFAULT_EMAIL_HOST variables in /etc/mailman/mm_cfg.py :

    DEFAULT_URL_HOST   = fqdn 
    DEFAULT_EMAIL_HOST = fqdn

or

    DEFAULT_URL_HOST   = mailserver.somemail.tld 
DEFAULT_EMAIL_HOST = somemail.tld
  1. Restart mailman service:
    # /etc/init.d/mailman restart
Have more questions? Submit a request
Please sign in to leave a comment.