Statistics page fails to open with error: Plugin load for plugin 'geoip' failed

Created:

2016-11-16 12:52:45 UTC

Modified:

2017-08-16 16:02:54 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Statistics page fails to open with error: Plugin load for plugin 'geoip' failed

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux

Symptoms

The following error appears when you try to open domain's web statistics at https://example.com/plesk-stat/webstat/

Error: Plugin load for plugin 'geoip' failed with return code: Error: Can't locate Geo/IP.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl . /usr/share/awstats/lib /usr/share/awstats/plugins) at (eval 3) line 1. Can't locate Geo/IP/PurePerl.pm in @INC (@INC contains: /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl . /usr/share/awstats/lib /usr/share/awstats/plugins) at (eval 4) line 1. Error: Need Perl module Geo::IP or Geo::IP::PurePerl

Setup ('/opt/psa/etc/awstats/awstats.example.com-http.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).

Cause

Perl plugins Geo::IP and Geo::IP::PurePerl are not installed or the module is not enabled.

Resolution

Configure the GeoIP module according to article #115002097389 .

Have more questions? Submit a request
Please sign in to leave a comment.