Unable to execute php.exe on behalf of psaadm user in Plesk 12.5

Created:

2016-11-16 12:52:32 UTC

Modified:

2017-08-08 13:32:17 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to execute php.exe on behalf of psaadm user in Plesk 12.5

Applicable to:

  • Plesk 12.5 for Windows

Symptoms

Unable to execute php.exe and php-cgi.exe processes in Plesk 12.5: binary configuration file is not read because it is executed on behalf of psaadm user.

Cause

In Plesk 12.5, PHP event handlers were separated from Plesk into different processes. php.exe and php-cgi.exe can be executed only by SYSTEM user. This functionality is hardcoded in Plesk 12.5. In Plesk 12.0, on the other hand, PHP event handlers could be executed by psaadm user.

Workaround

In future Plesk releases it is expected that php.exe and php-cgi.exe can be run on behalf of psaadm user.

Have more questions? Submit a request
Please sign in to leave a comment.