Plesk Migrator: Unable to start migration

Refers to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.5 for Windows

Created:

2016-11-16 12:52:29 UTC

Modified:

2017-01-31 07:37:17 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk Migrator: Unable to start migration

Symptoms

Plesk Migrator fails with following error from GUI:

Error: Unable to start migration. Please check specified IP address, administrator login and password and try again. If issue still reproduced, refer logs to further investigation.

On target host %plesk_dir%\\var\\modules\\panel-migrator\\sessions\\<sessiontimestamp>\\debug.log have the following data:

+|2015-11-02_08:25:24,017|D|MT|core.workflow.runner.by_subscription|||Checking whether it is required to execute action
+|2015-11-02_08:25:24,017|D|MT|core.workflow.runner.by_subscription|||START: Get operation progress in current session
+|2015-11-02_08:25:24,017|D|MT|core.workflow.runner.by_subscription|||FINISH: Get operation progress in current session
+|2015-11-02_08:25:24,017|D|MT|core.workflow.runner.by_subscription|||Exit common action block

info.log and debug.log files on the destination server have the following error:

URLError: <urlopen error [Errno 10054] An existing connection was forcibly closed by the remote host> PleskConnectionCheckError: Failed to connect to target Plesk server by Plesk API: <urlopen error [Errno 10054] An existing connection was forcibly closed by the remote host>

On the source server <Migrator Temporary directory>\\panel-transfer-agent\\debug.log have the following data:

[2015-11-02 08:23:28,717] [INFO] parallels | Command '"C:\\Program Files (x86)\\Parallels\\Plesk\\python\\python.exe" "C:\\Program Files (x86)\\Parallels\\Plesk\\/admin/plib/modules/panel-migrator/backend/plesk-migrator.py" "C:\\Program Files (x86)\\Parallels\\Plesk\\/var/modules/panel-migrator/" generate-migration-list  "C:\\Program Files (x86)\\Parallels\\Plesk\\/var/modules/panel-migrator/sessions/20151102081810/config.ini"' executed successfully at 192.168.0.1
[2015-11-02 08:23:28,809] [ERROR] parallels | Failed to receive length of a command
[2015-11-02 08:23:28,809] [DEBUG] parallels | Exception:
Traceback (most recent call last):
File "server.py", line 36, in log_failure
yield
File "server.py", line 218, in handle
length = self._receive(4)
File "server.py", line 250, in _receive
r = self.request.recv(size - len(b))
File "C:\\panel_migrator\\panel-transfer-agent\\python\\lib\\ssl.py", line 241, in recv
return self.read(buflen)
File "C:\\panel_migrator\\panel-transfer-agent\\python\\lib\\ssl.py", line 160, in read
return self._sslobj.read(len)
error: [Errno 10054] An existing connection was forcibly closed by the remote host
[2015-11-02 08:23:28,825] [INFO] parallels | Finished connection from '123.123.123.123'

Cause

Target server behind NAT or some ports are blocked by firewall.

Resolution

  • Ensure that firewall is configured to pass the following ports:

    TCP ports 135, 139, 445 and UDP ports 137, 138. Be sure to open these ports on the source and on the target server.
    TCP port 1433 for MS SQL, if it is used as the default instance.
    UDP port 1434 and all (or manually selected) TCP ports for MS SQL, if it is used as a named instance.
    TCP port 10155 for a custom Plesk Migrator service performing miscellaneous tasks.
    TCP port 10156 for rsync server.
    TCP port 8443 for access to Plesk XML API on the target server and on the source servers, if migrating from Plesk.
    TCP ports 110, 143 for POP3 and IMAP, on source and target servers. These are used for post-migration checks.
  • Ensure that UAC (User Account Control) is disabled in case if username provided as 'administrator login' member of Administrators group, but not windows administrator.

  • Ensure that target server is not behind NAT and routing is configured properly.

Workaround

Try to use Plesk Migrator CLI

  1. You need to configure migration - specify access to source and target servers:

    Copy file %plesk_dir%\\admin\\plib\\modules\\panel-migrator\\backend\\conf\\samples\\plesk-windows.simple.ini into <PLESK_DATA_DIRECTORY>\\var\\modules\\panel-migrator\\conf\\config.ini , where PLESK_DATA_DIRECTORY could be retrieved from registry:

    reg query "HKLM\\SOFTWARE\\Plesk\\PSA Config\\Config" /v PRODUCT_DATA_D /reg:32
  2. Edit just created config.ini and specify the following options:

  3. ip of target Plesk server (in section plesk)
  4. ip of source Plesk server (in section pfw),
  5. windows-password - password of user Administrator on source Plesk server

  6. Try to generate migration list - list of objects on source server, which can be migrated: domains, clients, resellers, etc:

    cmd.exe /C "%plesk_dir%admin/plib/modules/panel-migrator/backend/plesk-migrator.bat" generate-migration-list

After that you can edit generated list ( \var\modules\panel-migrator\sessions\migration-session\migration-list by default) - for example, remove some domains, that you won't to migrate, or reassign it to another vendors, and finally run migration:

cmd.exe /C "%plesk_dir%admin/plib/modules/panel-migrator/backend/plesk-migrator.bat" transfer-accounts

Additional information available in Migration Guide on Plesk Documentation and Help Portal

Should you encounter a problem on any of these steps, please contact Plesk technical support.

Have more questions? Submit a request
Please sign in to leave a comment.