Unable to update PHP handler in Plesk 12.5 - Cannot modify system handler with id edit corresponding config file instead

Refers to:

  • Plesk 12.5 for Linux

Created:

2016-11-16 12:52:20 UTC

Modified:

2016-12-21 19:25:11 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to update PHP handler in Plesk 12.5 - Cannot modify system handler with id edit corresponding config file instead

Symptoms

An attempt to update PHP handler fails with the following error:

# /usr/local/psa/bin/php_handler --update -id cgi -displayname 'PHP 5.4.16 (Long Term Support)'

[2015-09-02 12:14:09] ERR [util_exec] proc_close() failed ['/usr/local/psa/admin/bin/php_handlers_control' '--update' '--id' 'cgi' '--displayname' 'PHP 5.4.16 (Long Term Support)'] with exit code [1]
Unable to update the PHP handler: Cannot modify system handler with id=`cgi': edit corresponding config file instead.

Cause

Behaviour by design.

Resolution

PHP handlers management is considered to be improved in one of the next Plesk version.

Have more questions? Submit a request
Please sign in to leave a comment.