How to check if Apache with SNI support is installed

Created:

2016-11-16 12:52:16 UTC

Modified:

2017-04-24 12:09:09 UTC

0

Was this article helpful?


Have more questions?

Submit a request

How to check if Apache with SNI support is installed

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Information

This article provides instructions on how to check if the Server Name Indication ( SNI ) extension is installed on your server.

To check if the Apache web server with SNI support is installed, use the Autoinstaller utility.

Check if "Apache web server with SNI support" is included in the list of installed components: \# /usr/local/psa/admin/sbin/autoinstaller --select-release-current --show-components |grep SNI  apache-sni        [up2date] - Apache web server with SNI support

You can check it with this package:

# rpm -qa |grep sni
apache-sni-configurator-2.2.22-12051419

Or this command:

    [root@test]# cat /etc/psa/psa.conf | grep SNI
# SNI
SNI_SUPPORT true

NOTE: Some operating Systems support SNI by default, so it will not be avaiable in Plesk autoinstaller for installation. Operating Systems that support SNI by default:

Redhat enterprise Linux 6.x and later
Fedora 10 and later
Centos 6.x SNI
Debian 6.x and later
Ubuntu 10.04 and later
Have more questions? Submit a request
Please sign in to leave a comment.