Application pool stops randomly within in a specified time period. What can be possible reason?

Created:

2016-11-16 12:51:24 UTC

Modified:

2017-08-16 17:26:05 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Application pool stops randomly within in a specified time period. What can be possible reason?

Applicable to:

  • Plesk 10.x for Windows
  • Plesk 11.x for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows
  • Plesk 9.x for Windows

Symptoms

Application pool stops randomly within in a specified time period. What can be possible reason?

Cause

One of possible reason may be Rapid Fail Protection in IIS. Rapid-Fail Protection disables application pool if it crashes several times within in a specified time period. It prevents the failing application pool from getting into a continuous loop of crashing. This is useful when an application goes out of control which could overload the server.

Resolution

To prevent an Application Pool from stopping, you can disable Rapid Fail Protection in IIS, please refer to this article for more information:

http://www.iis.net/configreference/system.applicationhost/applicationpools/add/failure

http://technet.microsoft.com/en-us/library/cc745955.aspx

General instruction to disable Rapid Fail Protection for application pool is the following:

  1. Open Internet Information Services (IIS) Manager->Application pools->choose application pool->Advanced Settings

  2. Scroll down to Rapid Fail Protection and change the option Enabled from true to False. Click OK to apply the changes.

Have more questions? Submit a request
Please sign in to leave a comment.