Mail delivery to an external domain fails: mail loops back to myself

Refers to:

  • Plesk 11.0 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:51:15 UTC

Modified:

2016-12-21 19:22:42 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Mail delivery to an external domain fails: mail loops back to myself

Symptoms

Mail to anexternal domain is not delivered. The following information can be found in /usr/local/psa/var/log/maillog :

    status=bounced (mail for example.com loops back to myself)

Cause

IP Address of MX record for recepient's domain points to Plesk server. So, Postfix tries to send email to itself.

Resolution

Check if IP address of the recepient's domain belongs to the Plesk server:

#host example.com
example.com has address 203.0.113.2
example.com mail is handled by 0 example.com.
# ifconfig | grep 203.0.113.2
inet addr:203.0.113.2 Bcast:203.0.113.15 Mask:255.255.255.0
# cat /etc/sysconfig/network-scripts/ifcfg-eth0-range0
IPADDR_START=203.0.113.1
IPADDR_END=203.0.113.14
NETMASK=255.255.255.0
CLONENUM_START=0

On the example above IP address 203.0.113.2 belongs to sender server. That is why Postfix falls in loop.

In this case, delete IP address 203.0.113.2 from Plesk server and restart network service:

# service network restart

After that, make sure that IP address 203.0.113.2 does not point to the server anymore.

Note: If the maillog contains the server name, instead of domain name, please, add the server name ' server1.net ' to the mydestination line in /etc/postfix/main.cf and then, restart Postfix:

# grep mydestination /etc/postfix/main.cf
mydestination = localhost.$mydomain, localhost, localhost.localdomain, server1.net
#/etc/init.d/postfix restart
Have more questions? Submit a request
Please sign in to leave a comment.