The Yum utility failed to install the required packages: missing dependency for mysql-devel

Refers to:

  • Plesk for Linux

Created:

2016-11-16 12:50:57 UTC

Modified:

2016-12-21 19:22:05 UTC

0

Was this article helpful?


Have more questions?

Submit a request

The Yum utility failed to install the required packages: missing dependency for mysql-devel

Symptoms

Cannot upgrade components due to The Yum utility failed to install the required packages:

Exception: Failed to solve dependencies:
Missing Dependency: libmysqlclient.so.15 is needed by package mysql-devel-5.0.95-5.el5_9.i386 (installed)
Missing Dependency: mysql = 5.0.95-5.el5_9 is needed by package mysql-devel-5.0.95-5.el5_9.i386 (installed)
Missing Dependency: libmysqlclient_r.so.15 is needed by package mysql-devel-5.0.95-5.el5_9.i386 (installed)

Cause

Package mysql-devel-5.0.95-5.el5_9.i386 is not shipped with Plesk

Resolution

Remove this package using yum utility:

# yum remove mysql-devel-5.0.95-5.el5_9
Have more questions? Submit a request
Please sign in to leave a comment.