Blacklisting for spam protection does not work

Created:

2016-11-16 12:50:41 UTC

Modified:

2017-08-16 16:49:29 UTC

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Blacklisting for spam protection does not work

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Symptoms

We have configured spam protection with black listing. The system does not block messages are coming from blacklisted IP address. Server would not be rejecting mail from IP’s listed at zen.spamhaus.org

Cause

Some public DNS providers wisely implement non-hijacked responses for known DNSBL zones like Spamhaus.

Resolution

Check what DNS resolvers you are using: If you are using a free DNS servers like Google Public DNS, in most cases you will receive a not listed (NXDOMAIN) reply from Spamhaus’ public DNSBL servers. Please use your own DNS servers when doing DNSBL queries to Spamhaus.

Reference: http://www.spamhaus.org/faq/answers.lasso?section=DNSBL%20Usage#261

In other words, commonly used public resolvers such as Google’s (8.8.8.8 / 8.8.4.4) and 4.2.2.1 – 4.2.2.6 would not work with SpamHaus.

Proper DNS response:

# dig +short TXT 2.0.0.127.zen.spamhaus.org
"http://www.spamhaus.org/sbl/query/SBL233"
"http://www.spamhaus.org/query/bl?ip=127.0.0.2"

As workaround you can specify other DNS servers. For example, OpenDNS Home :

208.67.222.222  
208.67.220.220
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