Joomla installation fails with: The app requires the mysql database server version 5.1 or later

Created:

2016-11-16 12:50:33 UTC

Modified:

2017-04-24 12:10:01 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Joomla installation fails with: The app requires the mysql database server version 5.1 or later

Applicable to:

  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk
  • Plesk 12.0 for Windows
  • Plesk 10.3 for Linux
  • Plesk 10.2 for Linux

Symptoms

Joomla installation fails with the following error:

Error: Unable to install the app because its installation requirements are not met. Contact your hosting provider to resolve this problem.
Requirements
Database
The app requires the mysql database server version 5.1 or later.

Cause

The MySQL server version was not updated in the 'psa.DatabaseServers' table during a Plesk upgrade which also involved the upgrade of the MySQL server.

This is a confirmed software issue with the ID PPPM-766

Resolution

  1. Backup the psa database:

    #  MYSQL_PWD=`cat /etc/psa/.psa.shadow`  mysqldump -uadmin psa > /tmp/psa.`date +%F_%H.%M`.sql
  2. Check your installed MySQL version:

    # mysql -V
    mysql Ver 14.14 Distrib 5.5.30, for Linux (x86_64) using readline 5.1
  3. Check the MySQL version specified in the psa.DatabaseServers table:

    # MYSQL_PWD=`cat /etc/psa/.psa.shadow`  mysql -uadmin psa -Ne"select * from DatabaseServers where type='mysql'"
    +---+-----------+------+-------+-------+----------+----------+--------+---+
    | 1 | localhost | 3306 | mysql | admin | ******** | no_error | 5.1.73 | 0 |
    +---+-----------+------+-------+-------+----------+----------+--------+---+
  4. Update the MySQL version in the psa.DatabaseServers table:

    #  MYSQL_PWD=`cat /etc/psa/.psa.shadow`  mysql -uadmin -e"update DatabaseServers set server_version='5.5.30' where id = 1"
Have more questions? Submit a request
Please sign in to leave a comment.