Applicable to:
- Plesk for Linux
- Plesk for Windows
Symptoms
-
Unable to remove a domain from within customer's account in Plesk: option
Remove
is missing -
Domain in question is the main domain of a subscription (it has the same name as the subscription name).
-
Subscription that domain belongs to has 'Domains management' permission in Subscriptions > example.com > Customize > Permissions
Cause
This is by design. Customers do not have the ability to create or remove their subscriptions, only additional domains under already created subscriptions. Main domain can be removed only along with subscription by Plesk administrator or a Reseller who owns the customer. In that case all additional domains under the subscription will be removed as well.
Subscription is always associated with some service plan (custom one or from the set of already created ones), which is a set of hosting resources and services that administrator offers to customers for sell. To prohibit ability for customers to assign resources and services for themselves by their own, it is not allowed for them to create/remove subscriptions.
Resolution
The main domain of any subscription cannot be deleted by a customer. However, it can be renamed.
To actually remove the main domain, it is required that removal is performed by a Plesk administrator or a reseller who owns the customer in question. For more details, visit Plesk Administrator Guide.
Note: All additional domains under the subscription will be removed as well.
Comments
0 comments
Please sign in to leave a comment.