Plesk for Windows
kb: fixed
kb: bug
ext: wptk
ABT: Group B
Applicable to:
- Plesk for Windows
Symptoms
- The login button for WordPress, Typo3 or other CMS in Plesk for Windows is not working: it redirects to the application login page with empty credentials fields.
- ModSecurity Tradeoff/Thorough modes are enabled in Plesk > Tools & Settings > Web Application Firewall > Settings.
-
Login to PHP application using POST request fails without any error messages.
Cause
Product issue:
-
#PPPM-13504 "When users select the “Tradeoff” or “Thorough” configurations in ModSecurity, they now see the confirmation dialog, which informs that these configurations may disrupt operation of WordPress websites."
Fixed in:- Plesk Obsidian 24 May 2022 (Windows)
Resolution
Please consider updating your server:
Workaround
If update is not possible for some reason you may try the following
workaround
Until the bug will be fixed, apply the following workaround:
-
Go to Tools & Settings > Web Application Firewall (ModSecurity) > Settings.
-
Add the line below into the Custom directives field:
CONFIG_TEXT: SecStreamInBodyInspection on
-
Scroll down and press the OK button to apply the changes.
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