Applicable to:
- Plesk for Linux
Symptoms
-
Emails sent from a Plesk server to particular domains are not delivered and lay in the mail queue as deferred in Plesk at Tools & Settings > Mail Server Settings > Mail Queue.
-
One of the following error messages appear in
/var/log/maillog
:CONFIG_TEXT: 0572C2801E1: from=john.doe@example.com, size=3826, nrcpt=1 (queue active)
0572C2801E1: host mx.example.net refused to talk to me: 554 IP=IP_ADDRESS - A problem occurred. (Ask your postmaster for help or to contact info@mx.example.net to clarify.) (BL)
CONFIG_TEXT: connect to example.com[203.0.113.2]:25: Connection refused E37F6A0AF5: to=<notify@example.com>, relay=none, delay=371, delays=371/0.02/0.02/0, dsn=4.4.1, status=deferred (connect to example.com[203.0.113.2]:25: Connection refused)
CONFIG_TEXT: 3B0F8A08BF: host example.com[203.0.113.2] refused to talk to me: 554 5.7.1 You are not allowed to connect.
Cause
Error code 554 means IP-Blocking: A remote mail server is not currently accepting emails from a server IP address. This IP blocking may be due to a previously observed unusual volume of emails at the IP address concerned.
Resolution
Contact the administrator of remote mail server/mail relay server to find out the cause.
For more information about a blacklisted mail server, visit this KB article.
Comments
2 comments
Thanks for the article. I find the solution "> Contact administrator of a remote mail server", although fairly accurate, not entirely helpful and way too brief.
The fact of the matter with some of the most complex spamming issues it's not entirely possible to just "contact the administrator". Two notable example as iCloud and Microsoft. Both do not subscribe to the traditional idea of a block list and you cannot use tools such as MX Toolbox to find out if you've been listed there.
The big issue with blocking is it can lead to lost business - clients irate because you've been blocked and their email is not delivering. How often have I heard threats of cancelling because of blocking.
What would have have this article more help is links to some of these 3rd party services, or a link to some of the most common unblocking sites.
Hello Eugene van der Merwe
Thank you for sharing your user experience.
As for sharing links to some specific 3rd-party services, the choice is to be made by the customer.
We're not planning to add such links.
Thank you for understanding.
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