Domain shows PHP error: Directive 'safe_mode' is no longer available in PHP in Unknown on line 0

Refers to:

  • Plesk 12.5 for Linux
  • Plesk 10.4 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Created:

2016-11-16 12:48:47 UTC

Modified:

2016-12-21 19:16:28 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Domain shows PHP error: Directive 'safe_mode' is no longer available in PHP in Unknown on line 0

Symptoms

After upgrading PHP to version 5.3 or 5.4, domain's PHP pages show the error:

PHP Fatal error:  Directive 'safe_mode' is no longer available in PHP in Unknown on line 0

OR

The following error appears during WordPress installation:

Error: Installation of WordPress at http://domain.tld/wordpress failed. Non-zero exit status returned by script.

Cause

safe_mode directive is deprecated in PHP 5.3 and removed in PHP 5.4 and higher. Please check PHP documentation for details .

Resolution

Turn off/comment safe_mode option in all php.ini that used by original/additional PHP handlers.

Have more questions? Submit a request
Please sign in to leave a comment.