Server-wide settings for spamassasin are not applied

Created:

2016-11-16 12:48:07 UTC

Modified:

2017-04-24 11:02:39 UTC

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Server-wide settings for spamassasin are not applied

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Symptoms

I have enabled Spam Assassin:

In Tools & Settings > Spam Filter Settings tab disabled the option " Apply individual settings to spam filtering " and enabled " Switch on server-wide SpamAssassin spam filtering ".

but emails are not checked by SpamAssassin.

Cause

In Plesk option Switch on server-wide SpamAssassin spam filtering responsible only for SpamAssassin service status, on or off .

Such behavior is considered to be a software issue PPPM-1651 and will be fixed in future product updates.Please use provided ID to track maintanance in Plesk release notes .

Subscribe to our knowledge base - each product update comes with corresponding KB article:

http://kb.plesk.com/rss/index.html

Workaround

Note: Workaround can be applied to Plesk 11.5

If you want to enable SpamAssassin and apply settings which you have specified in Tools & Settings > Spam Filter Settings to all mailboxes, following steps are required:

  1. Switch on SpamAssassin:

    Tools & Settings > Spam Filter Settings . Enable option " Switch on server-wide SpamAssassin spam filtering ".

  2. Allow the client to apply individual settings of SpamAssassin for each mailbox:

    Tools & Settings > Spam Filter Settings . Enable option " Apply individual settings to spam filtering "

  3. Enable option " Switch on spam filtering for this email address " for all mailboxes:

    • Backup of psa database:

       MYSQL_PWD=`cat /etc/psa/.psa.shadow`  mysqldump -uadmin psa > psa.dump.`date +%F.%s`.sql
    • Execute following command:

      #  MYSQL_PWD=`cat /etc/psa/.psa.shadow`  mysql -uadmin psa -NBe"select concat(mail_name,'@',name) from mail m left join domains d on m.dom_id=d.id where spamfilter='false';" | while read i;do echo $i;/usr/local/psa/bin/spamassassin -u $i -status true;done
  4. Disable option " Apply individual settings to spam filtering ":

    Tools & Settings > Spam Filter Settings > Apply individual settings to spam filtering .

If you want to allow custom SpamAssassin configuration on each mailbox, we need to enable option from step 4 , and configure settings of all desired mailboxes:

  • Enable Tools & Settings > Spam Filter Settings > Apply individual settings to spam filtering .

  • Configure Subscriptions > desired subscription > Mail tab > desired mailbox > Spam Filter tab

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