Panel shows wrong control links "[[activePanelSessions]]" and "[[activeFtpSessions]]"

Created:

2016-11-16 12:48:05 UTC

Modified:

2017-04-24 12:11:18 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Panel shows wrong control links "[[activePanelSessions]]" and "[[activeFtpSessions]]"

Applicable to:

  • Plesk 11.5 for Linux
  • Plesk 12.0 for Linux

Symptoms

Within the ' Tools & Settings ' screen in our Panel, there are some odd display values:

"[[admin.controllers.server.tools.securityPanel]]", which includes the
options "[[activePanelSessions]]" and "[[activeFtpSessions]]".

Cause

The file ' /usr/local/psa/admin/panel/application/resources/languages/en-US/controllers/server/Tools.php ' realted to Plesk Core Package was corrupted.

Resolution

Replace the corrupted file with valid one from repository package. To perform this please follow the steps bellow:

  1. Make sure that ' Tools.php ' file was not replaced by insalling MU. Open ' /tmp/autoinstaller3.log ' file an search through with ' Tools.php ', you should have no results found.

  2. Download the ' plesk-core_11.5.30 ' package according to your system in Plesk repository: http://autoinstall.plesk.com/PSA_11.5.30/

  3. Extract the package:

RPM

#rpm2cpio mypackage.rpm | cpio -vid

DEB

First, extract the aforementioned three files from the DEB file (ar archive):

#ar vx mypackage.deb

Second, extract the contents of data.tar.gz using tar:

#tar -xzvf data.tar.gz
  1. Replace your ' Tools.php ' with one from the package:
    cp ./usr/local/psa/admin/panel/application/resources/languages/en-US/controllers/server/Tools.php /usr/local/psa/admin/panel/application/resources/languages/en-US/controllers/server/Tools.php
Have more questions? Submit a request
Please sign in to leave a comment.