Plesk for Linux
kb: technical
ABT: Group B
Applicable to:
- Plesk for Linux
Symptoms
-
Plesk shows 502 Bad Gateway error;
-
The service sw-engine is not running:
# service sw-engine status
● sw-engine.service - Startup script for Panel sw-engine
Loaded: loaded (/usr/lib/systemd/system/sw-engine.service; enabled; vendor preset: disabled)
Active: inactive (dead) since Mon 2018-03-26 21:57:49 +07; 5min ago
Cause
sw-engine service is stopped. This may occur if upgrade attempt was unsuccessful or it was stopped manually.
Resolution
For Plesk Onyx 17.8
- Click Open Repair Kit and log in with Plesk admin credentials.
- If it was successful, try starting sw-engine service by clicking Restart Processes
- If it was successfully started, click Log In to Plesk button
For other Plesk versions
-
Connect to the server via SSH.
-
Start sw-engine service:
# service sw-engine start
Or start psa service:
# service psa start
Comments
7 comments
I have the same problem after the update with every login.
How do I get the error permanently solved?
I am having exactly this issue, sadly after some seconds/minutes my panel is offline again. Has anyone solved?
in my case this was the fix: PPPM-10653 https://docs.plesk.com/release-notes/onyx/change-log/#plesk-17811-mu92
Hello cilap and Fabian Flasche
I would suggest starting with checking /var/log/sw-cp-server/sw-engine.log
For the list of Plesk log files and configuration files refer here.
In case this won't help. submit a support request directly to Plesk or to our partner in case the license was purchased from one of our partners.
I am having exactly this issue, sadly after some seconds/minutes my panel is offline again
what logfile to check for the issue behind the 502? Any other suggestions?
hello plesk i have also this issue what is the solution
Hello soufianejayden,
The issue can have several reasons. Thus I recommend you open a request to Technical Support in order to check the issue further.
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