Unable to login to Plesk control panel: Unable to connect to pipe

Refers to:

  • Plesk 10.4 for Windows
  • Plesk 11.0 for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.0 for Linux
  • Plesk 12.5 for Windows

Created:

2016-11-16 12:46:51 UTC

Modified:

2016-12-21 19:11:48 UTC

0

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Unable to login to Plesk control panel: Unable to connect to pipe

Symptoms

Login to Plesk control panel shows the following error:

Error message or request description : Unable to connect to pipe \\\\.\\pipe\\P_7da1332a-fe05-4176-91f2-4c4457fb71f0
at (Con::ClientOverlappedPipe::create line 509)
at get shared instance of PleskSrvClient(PleskSrvClient::getInstance line 327)
at Unable to get administrator password: <Password has been wiped out for security reasons>
line 205)

Or:

ERROR: Exception: Access is denied. (Error code 5) at Unable to connect to pipe \\\\.\\pipe\\P_36a625a6-260f-44af-b844-3beee654dbd6<br> at (Con::ClientOverlappedPipe::create line 503)<br> at get shared instance of PleskSrvClient(PleskSrvClient::getInstance line 337)<br> at Unable to get administrator password:(zif_get_admin_password line 206) (Helper.php:68)
0: Helper.php:68
get_admin_password()
...
AutoPrepend->run()
9: auth.php:690

Cause

Plesk Management service has stuck or not started or not available.

Resolution

  1. Restart the Plesk Management service service.
  2. If it is not able to restart, kill the plesksrv.exe process from task manager and restart the service with poppass service.
  3. Run Plesk Reconfigurator-> Repair Plesk Installation select 'Plesk services'.
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