Applicable to:
- Plesk for Windows
Symptoms
-
An operation in Plesk fails with the error message:
PLESK_ERROR: Unable to lookup SID for name IUSR_example.com: (1332) No mapping between account names and security IDs was done.(Error code 1)
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A Plesk backup task fails with the error message:
PLESK_ERROR: Unable to back up files from C:\Inetpub\vhosts\example.com owned by system user. Error: Failed to create archive: Unknown error
PLESK_ERROR: Warning: Subscription "example.com"
Unable to back up files from C:\Inetpub\vhosts\example.com owned by system user. Error: Failed to create archive: Repository error: Archiver error: unable to pack C:/Inetpub/vhosts\example.com. Unable to logon system user 'jdoe' (domain: '') to impersonate. Using password: yes. Details: The user name or password is incorrect.. -
Migration finishes with the following warning:
PLESK_WARN: Can not deploy web-content of domain example.comWarning:ForeignMigratorCore.MigratorException: System.Exception: Get flags failed of user (IUSR_example.com): (2221) The user name could not be found.
-
When changing permissions in Plesk File Manager, the operation fails with the following error message:
PLESK_ERROR: PleskUtilException
filemng failed: The user name could not be found. (Error code 2221) at NetUserGetInfo((null), john) at (UserInformation::getUserInformation line 187) at getUserInformation(john)(UserInformation::getUserInformation line 193) at execute "D:\Program Files (x86)\Parallels\Plesk\admin\bin\filemng" john --permissions --list-common "--file=D:\Web\vhosts\example.com\httpdocs\wordpress\wp-content" "--accounts=fsgF93A.tmp"(RunTime::RunAsUser::run line 223) (Error code 1)
Cause
The user mentioned in the error message does not exist in the local system.
Resolution
-
Connect to the server via RDP.
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Apply the solution for all or several domains:
Run the following commands to fix all domains:
C:\> "%plesk_cli%/repair" --repair-all-webspaces-system-users
C:\> "%plesk_cli%/repair" --regenerate-web-server-users-password
C:\> "%plesk_dir%\bin\repair.exe" --repair-all-webspaces-security
C:\> "%plesk_cli%/repair" --synchronize-impersonation-storage
If one or several domains are affected, use the following commands:
C:\> "%plesk_cli%/repair" --repair-webspace-system-users -webspace-name example.com
C:\> "%plesk_cli%/repair" --repair-webspace-security -webspace-name example.com
C:\> "%plesk_cli%/repair" --synchronize-impersonation-storage
Comments
1 comment
I faced same issue and above commands were not resolved. It was showing below error when I tried to load plesk interface.:
Additionally, an exception has occurred while trying to report this error: Exception
Unable check file existence: No mapping between account names and security IDs was done. (Error code 1332) at Unable to lookup SID for name Plesk Administrator<br> at (RunTime::Sid::load line 87)<br> at Plesk impersonation(PipeServer::ServerThread::impersonateWithoutProfile line 750)<br> at (RunTime::PipeClient::readMessage line 117)<br> at Unable to call readMessage()(RunTime::PipeClient::readMessage line 122)<br> at Unable to call impersonateWithoutProfile()(RunTime::SIDClient::impersonateWithoutProfile line 383)<br> at Unable to call ClientAutoImpersonate()(RunTime::ClientAutoImpersonate::ClientAutoImpersonate line 455)<br> at (zif_plesk_internal_file_exists line 1437) (functions.php:1252)
Unable check file existence: No mapping between account names and security IDs was done. (Error code 1332) at Unable to lookup SID for name Plesk Administrator<br> at (RunTime::Sid::load line 87)<br> at Plesk impersonation(PipeServer::ServerThread::impersonateWithoutProfile line 750)<br> at (RunTime::PipeClient::readMessage line 117)<br> at Unable to call readMessage()(RunTime::PipeClient::readMessage line 122)<br> at Unable to call impersonateWithoutProfile()(RunTime::SIDClient::impersonateWithoutProfile line 383)<br> at Unable to call ClientAutoImpersonate()(RunTime::ClientAutoImpersonate::ClientAutoImpersonate line 455)<br> at (zif_plesk_internal_file_exists line 1437) (functions.php:1252)
Above solution did not worked .
Solution:
I followed instructions here to:
Restore Plesk Administrator and service accounts (type command in CMD Shell (Run As Administrator):
plesk sbin usermng --install-plesk-admin
the command above helped me to fix issue
Below is link to KB article :
How to recreate system users for Plesk on Windows
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