Plesk deployed on the Amazon EC2 web service has incorrect IP mapping after each restart.

Created:

2016-11-16 12:46:03 UTC

Modified:

2017-08-08 13:30:46 UTC

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Plesk deployed on the Amazon EC2 web service has incorrect IP mapping after each restart.

Applicable to:

  • Plesk Onyx for Linux
  • Plesk 12.5 for Windows

Symptoms

Plesk, which is deployed on the Amazon EC2 web service has incorrect IP mapping after each restart. It has mapping between several Elastic IP Addresses and public IPs, however after restart of VM there is only one public IP for all private IPs.

Cause

Elastic IP addresses are not being assigned to Amazon Virtual Machine instance

Resolution

  1. To avoid incorrect remapping between Elastic IP Addresses and Public IP address after restart it is required to configure your AWS instance properly as it is described in Plesk Documentation - Deployment on Amazon EC2 :

    It is recommended to attach your Elastic IP to the instance. In the left menu, select Elastic IPs and Allocate New Address, or select any existing unassociated address to be associated to your instance. After the Elastic IP attachment, reboot the instance and perform additional actions to configure Plesk (see the Changing IP Address section). Learn more about Elastic IP in the Amazon AWS documentation: Elastic IP Addresses
  2. Otherwise, disable Prepare public IP scheduled task in Windows Task Scheduler

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