- Plesk for Linux
- Plesk 12.5 for Windows
Joomla installation/upgrade fails with the error:
Error: Unable to install the app because its installation requirements are not met. Contact your hosting provider to resolve this problem.
The app requires PHP 5.3.10 or later. Your PHP is 5.3.3. If PHP is not available, ensure that the PHP support is selected for the domain.
What can be done in this situation?
Follow one of the given below suggestions suiting your requirements:
Install previous version of
a) In Domains > domain.tld > Applications open
joomlapage with app description.
b) Click on
Select another versionlink and choose previous version.
Ubuntu 14install additional
PHPversion from official repository using
yum install php
1. Atomic repository:
# wget -q -O - http://www.atomicorp.com/installers/atomic | sh
2. yum install php
PHPversion compiling additional
1. Download the source of the required php version.
2. Follow the /en/118378 to make it available on the server.
Make the newer version of
joomlaunavailable for installation and make available lower version of
joomlawhich is compatible with current
Go to Tools & Settings > Application Vault > My Apps > Add App
- Make it unavailable for customers
- Go to APS Catalog
Download the lower version of
joomlawhich is compatible with your
PHPversion on the server.
- Go to Tools & Settings > Application Vault > My Apps > Add App
Choose the option
Upload an APS package
Upload the package downloaded in the step (5), by clicking
Make it available to customers by selecting the check box
Make available to customers.
This will make only earlier version of
joomlaavailable for installation.