Applicable to:
- Plesk for Linux
Symptoms
Plesk sw-engine
process causes high CPU usage:
# ps aux | grep sw-engine
root 1242 0.0 0.3 348136 28732 ? Ss Jan14 0:14 /usr/bin/sw-engine -c /usr/local/psa/admin/conf/php.ini /usr/local/psa/admin/bin/modules/watchdog/wdcollect -c /usr/local/psa/etc/modules/watchdog/wdcollect.inc.php
root 2315 0.0 0.1 353260 9908 ? Ss Jan14 0:00 sw-engine-fpm: master process (/etc/sw-engine/sw-engine-fpm.conf)
root 3136 0.0 0.3 363840 32028 ? S Jan14 1:00 /usr/bin/sw-engine -c /usr/local/psa/admin/conf/php.ini /usr/lib64/plesk-9.0/psa-health-monitor-notification.php
Cause
Some sw-engine
child processes are stuck and cannot be stopped normally.
Resolution
-
Connect to the server via SSH.
-
Stop
sw-engine
service:# service sw-engine stop
Stopping sw-engine-fpm: [ OK ] -
Kill stuck processes:
# kill -9 <process_ID>
where
<process_ID>
are IDs of stucksw-engine
processes fromps aux
command -
Start
sw-engine
service:# service sw-engine start
Starting sw-engine-fpm: [ OK ]
Comments
5 comments
What is the long term solution to this problem? Is there an upgrade available to fix this problem? Please elaborate on how to prevent this from occurring in the first place.
@Bryan Muthig
There are various causes why fpm service can get stuck.
Such issues should be checked individually.
If you are facing such issue I recommend you submit a Support ticket:
How to submit a request to Plesk support?
I have this problem too with Plesk Obsidian Web Admin Edition Version 18.0.17.
Suddenly at random time, sw-engine hang 100% CPU and crazy high I/O load (I have 10 disks, with several partition, but with atop I see disk usage for all about 70%, something never happen normally, 10% is the maximum). Rester sw-engine correct the problem.
It's a Plesk script, so this is not normal something like this happen. That kill my website 2 times since yesterday and give me headache. Please, update your script for a protection against this. You can check the activity of sw-engine and restart the service when something not normal happen.
Hello @Alexis,
The described behavior isn't typical and required additional investigation. In case the issue is reproduced with the most recent version of Plesk Obsidian (RC4), this required additional investigation.
Please, could you submit a request to Plesk support: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-
I have a recurring problem with this.
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