Plesk sw-engine process causes high CPU usage

Follow

Comments

4 comments

  • Avatar
    Bryan Muthig

    What is the long term solution to this problem?  Is there an upgrade available to fix this problem?  Please elaborate on how to prevent this from occurring in the first place.

    0
    Comment actions Permalink
  • Avatar
    Bato Tsydenov

    @Bryan Muthig

    There are various causes why fpm service can get stuck.

    Such issues should be checked individually.

    If you are facing such issue I recommend you submit a Support ticket:

    How to submit a request to Plesk support?

    0
    Comment actions Permalink
  • Avatar
    Alexis

    I have this problem too with Plesk Obsidian Web Admin Edition Version 18.0.17.

    Suddenly at random time, sw-engine hang 100% CPU and crazy high I/O load (I have 10 disks, with several partition, but with atop I see disk usage for all about 70%, something never happen normally, 10% is the maximum). Rester sw-engine correct the problem.

    It's a Plesk script, so this is not normal something like this happen. That kill my website 2 times since yesterday and give me headache. Please, update your script for a protection against this. You can check the activity of sw-engine and restart the service when something not normal happen.

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello @Alexis,

    The described behavior isn't typical and required additional investigation. In case the issue is reproduced with the most recent version of Plesk Obsidian (RC4), this required additional investigation.

    Please, could you submit a request to Plesk support: https://support.plesk.com/hc/en-us/articles/213608509-How-to-submit-a-request-to-Plesk-support-

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request