Cannot activate/renew Sitebuilder license key: The productVersion parameter doesn't match current product version

Refers to:

  • Plesk Sitebuilder 4.5 for Linux
  • Plesk Sitebuilder 4.5 for Windows

Created:

2016-11-16 12:45:30 UTC

Modified:

2016-12-21 19:08:42 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Cannot activate/renew Sitebuilder license key: The productVersion parameter doesn't match current product version

Symptoms

I cannot activate license key of Parallels Plesk Sitebuilder 4.5. The following error occurs:

---8<---
Error: Could not activate/renew license. KA server response: The productVersion parameter doesn't match current product version
--->8---

Cause

It's by design that Parallels Plesk Sitebuilder cannot activate/renew the license key at Parallels Key Administrator if the design templates are outdated. Please refer to this KB article for more details:

Updating Parallels SiteBuilder to the latest version

[How to] How to verify that Parallels Plesk SiteBuilder is up-to-date and install the updates

Resolution

To activate your regular license key you should upgrade design templates to the latest version 4.5.9 (Linux) and 4.5.16 (Window) with the Design Templates Updater Utility. Here are release notes for both Linux and Windows editions:

Design Templates Updater Utility for SiteBuilder 3.x-4.x for Microsoft Windows

Design Templates Updater Utility for SiteBuilder 4.x for Linux

Have more questions? Submit a request
Please sign in to leave a comment.