After update process on CloudLinux some packages still the old version: Package already installed and latest version

Refers to:

  • Plesk 12.0 for Linux

Created:

2016-11-16 12:45:03 UTC

Modified:

2016-12-21 19:07:42 UTC

0

Was this article helpful?


Have more questions?

Submit a request

After update process on CloudLinux some packages still the old version: Package already installed and latest version

Symptoms

Package update is unable to complete, for example nginx , and following errors appears in /var/log/plesk/install/autoinstaller3.log :

Getting bootstrapper packages to installation list:
Following bootstrapper packages will be installed: (empty)

----------------

Getting packages to installation list:
Following packages will be installed: sw-nginx-1.6.0-1.14051516.rhel6.x86_64

----------------

Loaded plugins: fastestmirror, rhnplugin
Loading mirror speeds from cached hostfile
* cloudlinux-x86_64-server-6: cl-mirror.ptisp.com
Package sw-nginx-1.6.0-1.14051516.centos6.x86_64 already installed and latest version
Package sw-nginx-1.6.0-1.14051516.centos6.x86_64 already installed and latest version
Package sw-nginx-1.6.0-1.14051516.centos6.x86_64 already installed and latest version

or when update of Parallels Plesk to the latest version performed with Server Management > Tools & Settings > Updates and Upgrades > Update Components and despite successful update process there are still some packages (for example, plesk-l10n ) of the old version.

Cause

Such behavior when autoinstaller start using packages from CentOS Plesk repositories for CloudLinux instead of RedHat Plesk repositories known as internal software issue with ID #PPPM-2621 and was fixed in Plesk 12.0, microupdate #39.

Resolution

Apply the recent Plesk microupdates .

Workaround

  1. Clear yum cache:

    # yum clean all
  2. Reinstall package with autoinstaller.

Download the necessary package and install it manually if previous actions did not help.

Have more questions? Submit a request
Please sign in to leave a comment.