Apache warnings after update: VirtualHost overlaps

Refers to:

  • Plesk for Linux
  • Plesk 11.5 for Windows

Created:

2016-11-16 12:44:58 UTC

Modified:

2016-12-21 19:07:30 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Apache warnings after update: VirtualHost overlaps

Symptoms

After upgrade all the sites on the server stopped working. Apache stopped reading other configuration files. It is reading the first configuration file and directing all sites to the same site.Got the below warning on restarting apache/httpd :

[warn] VirtualHost 123.123.123.123:80 overlaps with VirtualHost 123.123.123.123:80, the first has precedence, perhaps you need a NameVirtualHost directive
[warn] VirtualHost 123.123.123.123:443 overlaps with VirtualHost 123.123.123.123:443, the first has precedence, perhaps you need a NameVirtualHost directive
[warn] VirtualHost 123.123.123.123:80 overlaps with VirtualHost 123.123.123.123:80, the first has precedence, perhaps you need a NameVirtualHost directive

Resolution

Repair vhost's structure:

# /usr/local/psa/bin/repair --update-vhosts-structure

Repair vhost's permissions:

# /usr/local/psa/bin/repair --restore-vhosts-permissions

Reconfigure web server:

# /usr/local/psa/admin/bin/httpdmng --reconfigure-all
Have more questions? Submit a request
Please sign in to leave a comment.