Plesk Installer fails to update/install components: The requested URL returned error: 404 Not Found

Follow

Comments

6 comments

  • Avatar
    JVAk

    I have a similar problem, Plesk auto-updater can't find the url of this package: http://autoinstall.plesk.com/PHP71_17/php71-ubt12.04-x86_64.plesk17.inf3

     

    I have Onyx17.0.17 and my OS is Ubuntu 12.04, also I use apt and not yum.

    This is the updater log:

    .....

    Downloading Extensions Catalog feed...
    Downloading file PSA_17.0.17/plesk-patches-17.0.17-ubt12.04-x86_64.inf3: 0%
    Downloading file PSA_17.0.17/plesk-patches-17.0.17-ubt12.04-x86_64.inf3: 100% was finished.
    Downloading file PMM_0.1.10/pmm-0.1.10-ubt12.04-x86_64.inf3: 0%
    Downloading file PMM_0.1.10/pmm-0.1.10-ubt12.04-x86_64.inf3: 100% was finished.
    Downloading file NGINX17/nginx-ubt12.04-x86_64.inf3: 0%
    Downloading file NGINX17/nginx-ubt12.04-x86_64.inf3: 100% was finished.
    Downloading file PHP52_17/php52-ubt12.04-x86_64.plesk17.inf3: 0%
    Downloading file PHP52_17/php52-ubt12.04-x86_64.plesk17.inf3: 100% was finished.
    Downloading file PHP53_17/php53-ubt12.04-x86_64.plesk17.inf3: 0%
    Downloading file PHP53_17/php53-ubt12.04-x86_64.plesk17.inf3: 100% was finished.
    Downloading file PHP54_17/php54-ubt12.04-x86_64.plesk17.inf3: 0%
    Downloading file PHP54_17/php54-ubt12.04-x86_64.plesk17.inf3: 100% was finished.
    Downloading file PHP55_17/php55-ubt12.04-x86_64.plesk17.inf3: 0%
    Downloading file PHP55_17/php55-ubt12.04-x86_64.plesk17.inf3: 100% was finished.
    Downloading file PHP56_17/php56-ubt12.04-x86_64.plesk17.inf3: 0%
    Downloading file PHP56_17/php56-ubt12.04-x86_64.plesk17.inf3: 100% was finished.
    Downloading file PHP70_17/php70-ubt12.04-x86_64.plesk17.inf3: 0%
    Downloading file PHP70_17/php70-ubt12.04-x86_64.plesk17.inf3: 100% was finished.
    Downloading file PHP71_17/php71-ubt12.04-x86_64.plesk17.inf3: 0%
    
    ERROR: Failed to download the file http://autoinstall.plesk.com/PHP71_17/php71-ubt12.04-x86_64.plesk17.inf3:
    The requested URL returned error: 404
    Not all packages were installed.
    Please try to install packages again later.
    Please resolve this issue and try to install the packages again.
    If you cannot resolve the issue on your own, contact product technical support for assistance.

     

     

  • Avatar
    Ivan Postnikov

    Hello @JVAk

    Ubuntu 12.04 has reached EOL and is not supported by Plesk Onyx, here you may see software requirements:

    https://docs.plesk.com/release-notes/onyx/software-requirements/

    The solution is to migrate to the server with supported OS.

    Alternatively, you may upgrade Ubuntu to supported version but this path is not recommended and should be done at your own risk.

  • Avatar
    JVAk (Edited )

    Hi, @Ivan-Postnikov,

    thanks for the answer.

     

    I'm in the process of migrating the server to a new one (thank god for plesk migration tool!), but in the meantime I need it to still be working.

     

    Despite the updating error, since I don't have php7.1 installed and none of my subscriptions use it everything seems to be working ok.

     

    But now I can't access the plesk update interface ( Tools & Settings -> Updates and Upgrades), when it changes to the port 8447 the browser shows this error: ERR_EMPTY_RESPONSE

     

    edit: the port 8447 is open in the firewall, the problem has been noticed after the updating error

  • Avatar
    Ivan Postnikov

    @JVAk

    Most probably Plesk installer has hung.

    Try searching for process and kill it, for example:

    # ps -auxww | grep installer
    root 12440 0.0 0.0 4068 1380 pts/0 Tl 23:11 0:00 plesk installer

    # kill 12440

    After that installer should be available again.

    Also try to access Plesk installer via CLI:

    #plesk installer

  • Avatar
    JVAk

    Thanks for the help, it works ok now.

  • Avatar
    Ivan Postnikov

    @JVAk

    Glad to know it helped =)

Please sign in to leave a comment.

Have more questions? Submit a request