Identifying a failed Pleskl for Linux upgrade

Refers to:

  • Plesk 12.5 for Windows

Created:

2016-11-16 12:44:42 UTC

Modified:

2016-12-21 19:06:51 UTC

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Identifying a failed Pleskl for Linux upgrade

Symptoms

The symptoms vary:

  • Updates/upgrades fail

  • Services refuse to start

  • Services malfunction
  • Errors in control panel
  • Migrations/backups fail

Cause

The Plesk installation may have suffered a failed upgrade.

Diagnostics

Note: If multiple services malfunction or refuse to start, check if there is enough free space on all disk partitions.

It is required to verify that all Plesk components are of the same version, so let us check them, one-by-one.

  • The installation itself:
    # cat /usr/local/psa/version
    10.4.4 CentOS 5 1013111102.18`

Note: For Debian-like systems, it is usually /opt/psa/version

  • version of PSA database:

    # MYSQL_PWD=`cat /etc/psa/.psa.shadow` mysql -u admin psa -e 'select * from upgrade_history order by upgrade_date desc limit 1'
    +---------------------+--------------+------------+
    | upgrade_date        | version_info | db_version |
    +---------------------+--------------+------------+
    | 2012-03-30 12:48:00 |       10.4.4 |     10.4.4 |
    +---------------------+--------------+------------+``

    Note: If you see no output, it means that your database has never been upgraded.

  • Installed packages:

    # rpm -q psa
    psa-10.4.4-cos5.build1013111102.18`

Note: For Debian-like systems, you may need to use the dpkg –l psa command.

If from the checking above versions do not match, it means that Plesk installation has suffered a failed upgrade in the past. Proceed to the Resolution section below. If all three versions match, and you were in the process of upgrading to version 10 from an earlier PP version, you may proceed with further troubleshooting using Parallels Plesk Panel Post-Upgrade Checker .

Resolution

  1. Try to find the reason for the upgrade failure in the autoinstaller log file /tmp/autoinstaller3.log

  2. Then search for the found error message in our knowledgebase .

If it is not possible to find solution by own, feel free to use available support options in Plesk Support portal .

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