Plesk upgrade fails with Segmentation fault error

Created:

2016-11-16 12:44:32 UTC

Modified:

2017-08-08 13:30:25 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk upgrade fails with Segmentation fault error

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

Plesk upgrade fails with Segmentation fault error:

...
File downloading PMM_0.1.10/pmm-0.1.10-cos6-x86_64.inf3: 33%..100% was finished.
gpg-pubkey-914bdf7e-55c05220 gpg(Plesk Team <info@plesk.com>)
gpg-pubkey-c105b9de-4e0fd3a3 gpg(CentOS-6 Key (CentOS 6 Official Signing Key) <centos-6-key@centos.org>)
Segmentation fault

There were failed attempts to upgrade Plesk earlier and its packages belongs to different Plesk versions.

If Plesk upgrade started in debug mode /usr/local/psa/admin/bin/autoinstaller --debug the following error occurs in /tmp/autoinstaller3.log :

[2016-02-26 12:46:08.087681] Impl: /usr/local/psa/bin/extension --get-xml-info heavy-metal-skin
[2016-02-26 12:46:08.219712] DEBUG detect extension package ext-heavy-metal-skin version: The file /usr/local/psa/bin/extension is part of Plesk distribution. It cannot be run outside of Plesk environment.

Cause

sw-engine package belongs to previous version of Plesk

Resolution

  1. Download appropriate version of sw-engine package from autoinstall.plesk.com , e.g. for Plesk 12.5.30 and CentOS 6:

    # wget http://autoinstall.plesk.com/PSA_12.5.30/dist-rpm-CentOS-6-x86_64/engine/sw-engine-2.16.2-centos6.201510051436.x86_64.rpm
  2. Upgrade sw-engine package as follows:

    # rpm -Uvh sw-engine-2.16.2-centos6.201510051436.x86_64.rpm --nodeps
  3. Restart upgrade using Plesk autoinstaller :

    # /usr/local/psa/admin/bin/autoinstaller
Have more questions? Submit a request
Please sign in to leave a comment.