On October 19, 2021, we have enabled single-sign-on for our Plesk Support Center to provide a seamless login/account experience. This implies that you’ll be able to use a single account across any of our web-facing properties.
If you had already registered your account at Plesk 360 (formerly known as My Plesk) please use one for login. Otherwise please re-register it using the same email address as your existing Zendesk login (support account). It’s essential that you use the same email address on our support center to ensure that your tickets stay attached to the same account.

How to uninstall Plesk for Linux

Follow

Comments

14 comments

  • Avatar
    Unknown User
    I get an error. Where to upload plesk._remove.zip file to ftp.

    unzip plesk._remove.zip unzip: cannot find or open plesk._remove.zip, plesk._remove.zip.zip or plesk._remove.zip.ZIP.
    0
    Comment actions Permalink
  • Avatar
    Konstantin Annikov

    Hello, 

    Thank you for the feedback. 

    I have modified the article. Extra "." symbol was defined in the command. Pleease try now with the following command after uploading file via ftp: 

    #  unzip plesk_remove.zip

    0
    Comment actions Permalink
  • Avatar
    Unknown User

    after connecting to the server, as root user, when I try executing the command plesk installer select-product-id plesk --remove-everything I get an error message, saying

    "ERROR: Unknown command: select-product-id"

    what am I doing wrong? 

     

    Thank you

    1
    Comment actions Permalink
  • Avatar
    Alexandr Redikultsev

    Hello, @Daniel Eliseo Wilson!

    Thank you for telling us, there was a typo there indeed, it should be --select-product-id, like:

    # plesk installer --select-product-id plesk --remove-everything

    I have adjusted the article accordingly.

    0
    Comment actions Permalink
  • Avatar
    Unknown User

    ok thank you very much. I now no longer get the error message mentioned above, but at a certain point, after several lines of code,  I get the following message:

    Detecting installed product components.

    ERROR: An internal error occured in auto-installer, rev.03ca0f11741a+ SourceManager.cpp, line 198.

    Not all packages were installed.

    Please contact product technical support.

    exit status 1

     

    And Plesk still remains installed

    Are you able to help me with this

    Thank you very much

     

     

    0
    Comment actions Permalink
  • Avatar
    Alexandr Tumanov

    @Daniel,

    try executing 'export LC_ALL=C' before starting AI. Make sure system package manager is correctly configured before AI starts and have no issues with dependencies.

    0
    Comment actions Permalink
  • Avatar
    bluecon

    It doesn't work because Plesk presenting following error:

    ....... >> snip << ......

    Reading package lists...
    Warning: not connected 'contrib' repository section
    Detecting installed product components.

    ERROR: An internal error occured in Plesk Installer 3.22.14, revision cef153794d9f, installer/SourceManager.cpp, line 196.
    Not all packages were installed.
    Please contact product technical support.
    exit status 1

    ....... >> snip << ......

     

    greetings

    bluecon

    0
    Comment actions Permalink
  • Avatar
    Nikita Nikushkin

    Hi @bluecon,

    Look like the "contrib" repository is missing in the repolist

    It is required to add it

    E.g. for Debain 8, open the "/etc/apt/sources.list" file via any text editor and add the "contrib" to it:

    deb http://ftp.debian.org/debian jessie main contrib non-free
    deb http://security.debian.org jessie/updates main contrib non-free
    0
    Comment actions Permalink
  • Avatar
    Valeria Lyakhova

    Hello,

    Please let me know how to uninstall Plesk from Ubuntu 18.4 WITHOUT rebuilding the server. Is there any script or something else? Mayby it is possible to remove it manually anyhow? 

    0
    Comment actions Permalink
  • Avatar
    Maxim Krasikov

    Hello @Valeria Lyakhova,

    Please let me clarify that there is no script which allows deleting Plesk on Ubuntu/Debian OSes.
    Re-deploying the server is the only supported scenario.

    0
    Comment actions Permalink
  • Avatar
    Markus Deger

    Hello,

    are you kidding, when will be this fixed? You asking to reinstall everything to get a buggy software out of my system? This is not called a workaround, it is called impudence.

    Best Regards

    Markus

     

     

     

     

     

    0
    Comment actions Permalink
  • Avatar
    Ivan Postnikov

    Hello @Markus,

    Thank you for the feedback.

    As I understand, before the need to uninstall Plesk you've had a technical issue with it.

    Could you, please, provide more information about the issue you've had? Maybe my colleague or I will be able to provide a solution.

    Also, you may create a request to Plesk Technical Support.

    Currently, there is no exact ETA regarding the fix for PI-498. However, it's recommended to not to install additional software on Plesk server as this software may conflict with one of Plesk components. Feel free to share your scenario.

    0
    Comment actions Permalink
  • Avatar
    Juri Derewjanko (Edited )

    This work for me. try this.

    I tested it twice, maybe you should do this multiple times because it doesn't always remove all packages of Plesk.

    Open the installer

    plesk installer

    go forward where u select the packages. Select your packages but unselect Plesk.

    only press ENTER... select with (F) doesn't work at my installer.

     

    It removes all the packages and Plesk on my Ubuntu Server 18.04

    ---

    The installer installs always the Obsidian Version.. I am not sure that it worked on the Onyx Version.

    1
    Comment actions Permalink
  • Avatar
    TecEgg

    Juri Derewjanko

    This actually worked. At least as far as possible. Later I used "dpkg -l" to display a list with the remaining packages. Just export the list and remove each Plesk package with "apt-get --purge remove plesk-name_of_package".

    @support it's really a shame that re-deployment is supposed to be a "workaround". My server also runs other services that are used productively. Migration here would be very inconvenient and should only be done when really necessary, not for something of uninstalling a software. Hope you get fix this bug so that we can easly deinstall your product.

     

    0
    Comment actions Permalink

Please sign in to leave a comment.

Have more questions? Submit a request