Applicable to:
- Plesk for Linux
Symptoms
-
Mail delivery from or to particular domain fails, the following bounce message is received:
Undelivered Mail Returned to Sender
(...)
<jdoe@example.com>: User unknown in virtual alias table -
The following record is found in
var/log/maillog
:postfix/trivial-rewrite[15060]: warning: do not list domain example.com in BOTH virtual_alias_domains and virtual_mailbox_domains
-
The domain
example.com
is present both invirtual_alias_domains
andvirtual_mailbox_domain
:# postmap -s hash:/var/spool/postfix/plesk/virtual |grep "^example.com"
example.com 1
# postmap -s hash:/var/spool/postfix/plesk/vmailbox | grep example.com
example.com/jdoe/Maildir/ -
Hostname might be changed automatically during Plesk installation
-
The domain is configured with capital letter in Domains > Example.com and server hostname is configured with capital letter in Tools & Settings > Server Settings
Cause
Software issue in Plesk with ID #PPPM-11246.
Resolution
Until the issue is resolved, apply the following workaround:
- Login to the server via SSH
- Change the hostname under Tools & Settings > Server Settings from Example.com to example.com and click OK
Comments
1 comment
Hi,
sadly the workaround does not fix the problem. Are there another workaround to fix this issue?
I've change the hostname to lowercase and even to another domain on this host. But both does not work.
Please sign in to leave a comment.