Unable to access MSSQL instance remotely: Unable to determine the TCP port number used by Microsoft SQL server

Created:

2016-11-16 12:42:45 UTC

Modified:

2017-04-24 11:02:11 UTC

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Unable to access MSSQL instance remotely: Unable to determine the TCP port number used by Microsoft SQL server

Applicable to:

  • Plesk Onyx for Windows
  • Plesk 11.5 for Windows
  • Plesk 12.0 for Windows
  • Plesk 12.5 for Windows

Symptoms

Unable to access MSSQL Server instance.

The following warning appears in Tools & Settings > Database Servers rs:

Warning: Unable to determine the TCP port number used by Microsoft SQL server '.\\MSSQLSERVER2014': TCP/IP protocol is not enabled in the server network configuration or the server is configured to use dynamic TCP ports.
To allow your customers to automatically configure firewall for remote database access, manually configure the SQL server to listen on a specific fixed TCP port.

Cause

MSSQL Server is not configured to use static ports in SQL Server Configuration Manager >

Resolution

Follow the article from Microsoft website Configure a Server to Listen on a Specific TCP Port (SQL Server Configuration Manager)

Note: During configuring, do not forget to remove 'TCP Dynamic Ports' values.

If the previous solution does not help, specify the port for MSSQL server under Plesk > Tools&Settings > Database servers > %name of the server% > Settings > Host name or IP address.

MSSQL server settings

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