Plesk update failed: apache2-mpm-prefork : Depends: apache2 (= 2.4.7-1ubuntu4.8) but 2.4.18-1+deb.sury.org~trusty+2 is to be installed

Created:

2016-11-16 12:42:12 UTC

Modified:

2017-08-16 17:37:04 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Plesk update failed: apache2-mpm-prefork : Depends: apache2 (= 2.4.7-1ubuntu4.8) but 2.4.18-1+deb.sury.org~trusty+2 is to be installed

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk Onyx for Linux
  • Plesk 11.x for Linux

Symptoms

Unable to install Plesk updates on Ubuntu 14.04. The following error is shown:

apache2-mpm-prefork : Depends: apache2 (= 2.4.7-1ubuntu4.8) but 2.4.18-1+deb.sury.org~trusty+2 is to be installed

OR

apache2-mpm-event : Depends: apache2 (= 2.4.7-1ubuntu4.5) but 2.4.18-1+deb.sury.org~trusty+2 is to be installed

Cause

3rd-party apache packages are installed. The following custom apache version does not have required apache2-mpm-prefork or apache2-mpm-event packages.

Resolution

  1. Disable the following 3rd-party repository:

    # ll /etc/apt/sources.list.d/
    ondrej-php5-trusty.list
  2. Get the list of 3rd-party apache packages:

    # dpkg -l | grep deb.sury.org | grep apache
    ii apache2 2.4.18-1+deb.sury.org~trusty+2
    ii apache2-bin 2.4.18-1+deb.sury.org~trusty+2
    ii apache2-data 2.4.18-1+deb.sury.org~trusty+2
    ii apache2-utils 2.4.20-1+deb.sury.org~trusty+3
  3. Using apt-get download download required packages with correct versions:

    # apt-get download apache2-bin=2.4.7-1ubuntu4.9

    where 2.4.7-1ubuntu4.9 is the current original package version for Ubuntu 14.04

  4. Install downloaded packages using dpkg -i :

    # dpkg -i apache2*

    Note : Make sure that current folder does not contain additional packages that have apache2 name.

  5. Run Plesk installer and complete update.

Have more questions? Submit a request
Please sign in to leave a comment.