Mail lists are not working: unable_to_run_/usr/lib/plesk-9.0/mm_wrapper:_file_does_not_exist/

Refers to:

  • Plesk 11.5 for Linux

Created:

2016-11-16 12:42:00 UTC

Modified:

2016-12-21 19:00:21 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Mail lists are not working: unable_to_run_/usr/lib/plesk-9.0/mm_wrapper:_file_does_not_exist/

Symptoms

Since the upgrade to Plesk 11.5 mailling lists aren't working anymore. The following error appears in the maillog:

preline:_fatal:_unable_to_run_/usr/lib/plesk-9.0/mm_wrapper:_file_does_not_exist/

Cause

By some reason the config files has the reference to non-existing file /usr/lib/plesk-9.0/mm_wrapper

grep mm_wrapper /var/qmail/mailnames/mydomain.com/.qmail-6gm

/var/qmail/bin/preline /usr/lib/plesk-9.0/mm_wrapper /usr/lib/mailman/mail/mailman leave fsm

Resolution

Remove the /usr/lib/plesk-9.0/mm_wrapper from all config files .qmail-*

sed -i 's/\\/usr\\/lib\\/plesk-9.0\\/mm_wrapper//g' /var/qmail/mailnames/mydomain.com/.qmail-*
Have more questions? Submit a request
Please sign in to leave a comment.