Operation "Complete Switching to the new Panel business model" could not be completed

Created:

2016-11-16 12:41:39 UTC

Modified:

2017-08-16 16:01:33 UTC

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Operation "Complete Switching to the new Panel business model" could not be completed

Applicable to:

  • Plesk 12.5 for Linux
  • Plesk 11.x for Linux

Symptoms

After upgrade to Plesk 11.5, option "Complete Switching to the new Panel business model" could not be completed despite the Plesk says it is completed. The task remains in Plesk Control panel->Tools and Settings .

Cause

Inconsistent information about domain administrator in "psa" database.

Resolution

  1. Create backup of psa database:

    # mysqldump -uadmin -p`cat /etc/psa/.psa.shadow ` psa >/var/lib/psa/dumps/psa1.dump
  2. Find domain administrator user:

    mysql> select id,name from domains where name='domain.tld';

    +-----+--------------+
    | id | name |
    +-----+--------------+
    | 523 | domain.tld |
    +-----+--------------+

    mysql> select * from dom_level_usrs where dom_id=523;

    +--------+------------+-------+---------+---------+--------+------+-----------+
    | dom_id | account_id | state | card_id | perm_id | passwd | uid | ownership |
    +--------+------------+-------+---------+---------+--------+------+-----------+
    | 523 | 977 | false | 93 | 2039 | | NULL | true |
  3. Check the account existence:

    mysql> select * from accounts where id=977;
    Empty set (0.00 sec)
  4. Insert a new record into accounts table:

    mysql> insert into accounts values (977, 'plain', '*****');
    Query OK, 1 row affected (0.00 sec)
  5. Try to switch subscription to a the new Panel business model once again.

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