Error installing SpamAssassin: Failed to solve dependencies: perl-Mail-DKIM-0.39-1.el5.noarch requires perl(:MODULE_COMPAT_5.8.8)

Created:

2016-11-16 12:40:56 UTC

Modified:

2017-08-18 23:53:00 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Error installing SpamAssassin: Failed to solve dependencies: perl-Mail-DKIM-0.39-1.el5.noarch requires perl(:MODULE_COMPAT_5.8.8)

Applicable to:

  • Plesk 12.5 for Linux

Symptoms

When install Spamassassin on Centos 6 with autoinstaller, the following error appears::

CONFIG_TEXT: Exception: Failed to solve dependencies:
perl-Mail-DKIM-0.39-1.el5.noarch requires perl(:MODULE_COMPAT_5.8.8)
Error: The Yum utility failed to install the required packages.

The same error you may see when try to install with yum:

# yum install perl-Mail-DKIM

Cause

Yum tries to download old package from Epel repository.

Resolution

1. Login to the server via SSH.

2. Disable Epel repository temporary: set enabled=0 in /etc/yum.repos.d/epel.repo and launch Plesk autoinstaller.

Have more questions? Submit a request
Please sign in to leave a comment.