Applicable to:
- Plesk for Linux
Symptoms
-
The Hard quota on disk space is not available for editing at Domains > example.com > Web Hosting Access page:
CONFIG_TEXT: Unlimited. Hard disk quota is not supported due to the configuration of the server file system
-
Migration of a subscription that uses hard disk quota fails:
PLESK_INFO: Failed to synchronize subscription with plan
Migration tools tried to perform operation in 3 attempts: Plesk error [1023]: quota - Description: hard disk quota is not supported due to configuration of server file system. Requested: 1073741824. Allowed: 0 -
Subscription cannot be synchronized with the corresponding service plan due to the following error:
PLESK_INFO: Syncing the subscription with its service plan failed because some of the services or resources defined in the plan cannot be actually provisioned with the subscription.
PLESK_INFO: "Information: Properties of the subscription example.com were set to correspond with the actual system state, they are still unsynced with the plan"
Available value indicates the actual state of a resource or a service in the system.
Clicking OK will initiate setting the subscription values according to the available values.OR:
PLESK_ERROR: ERR [panel] Unable to apply plan changes to domain. Error: The plan was not applied because of problems with the following functionality: hard disk quota is not supported due to configuration of server file system
-
User quota is not enabled:
# /usr/local/psa/admin/sbin/usermng --isquotable
usermng: Userquota is not enabled on device: /dev/mapper/centos-root
# plesk db "select * from ServiceNodeEnvironment where name='isHardQuotaEnabled'"
+---------------+---------+--------------------+-------+
| serviceNodeId | section | name | value |
+---------------+---------+--------------------+-------+
| 1 | os | isHardQuotaEnabled | false |
+---------------+---------+--------------------+-------+
Cause
Unconfigured disk quota in an operating system.
Resolution
Warning: configuring of the disk quota on the operating system is an administrative task and is not supported by Plesk.
All actions below are the common steps and performed at own risk.
Note: hard disk quota setup depends on the filesystem.
In the example below, the steps are performed for ext3
filesystem, while on another filesystem, e.g. xfs
, actions will be others.
Note: for Plesk Plesk Multi Server hard disk quota must be configured on both management and service nodes.
-
Connect to the server via SSH.
-
Make sure that the quota is supported by the kernel. It should be compiled into the kernel or loaded as a module.
To check if the quota is configured properly use this command:
# /usr/local/psa/admin/sbin/usermng --isquotable
Normally, it should return the "0" value.
If the utility returns the following error message:
CONFIG_TEXT: usermng: Unable to turn on user quota. User quota not supported on device '/dev/sda3'
System error 3: No such processOR
CONFIG_TEXT: usermng: Userquota is not enabled on device: /dev/mapper/centos-root
Then enable quota in the
/etc/fstab
file for the partitions on which Plesk stores data on, e.g. as follows:CONFIG_TEXT: /dev/hda1 / ext3 defaults,usrquota 1 1
-
Remount the partition:
# mount -o remount /
-
Create, check and repair quota files:
# /sbin/quotacheck -cfmvF vfsv0 /
Note: If the command is unknown, install
quota
package. -
Update the user quota with this command line:
# quotaon /dev/hda1
-
Make sure that the
aquota
format is used.There should be an
aquota.user
file in the root of every partition where the quota is enabled.If there is the
quota.user
file remove it and create correct one:Note: change the "/dev/hda1" device in commands below to the correct one.
# rm -f quota.user
# touch aquota.user
# /sbin/quotacheck -fmv /dev/hda1 -
Go to the Plesk > Tools & Settings > Server Components page and click the Refresh button to update information about quota.
Note: A separate component will not appear, but Plesk components cache will be updated to include new information and isHardQuotaEnabled will be true in psa database:
# plesk db "select * from ServiceNodeEnvironment where name='isHardQuotaEnabled'"
+---------------+---------+--------------------+-------+
| serviceNodeId | section | name | value |
+---------------+---------+--------------------+-------+
| 1 | os | isHardQuotaEnabled | true |
+---------------+---------+--------------------+-------+
-
Make sure that the
quotaugidlimit
parameter is not set to zero and that it is greater than the number of users and groups in the CT. This limit can be adjusted from the Hardware Node with the following:# vzctl set CTID --quotaugidlimit 500 --save
# vzctl stop CTID
# vzctl start CTIDWhere CTID is the ID of the Virtuozzo container with Plesk.
-
Execute the
packagemng
utility to recreate the backend cache in Plesk:# /usr/local/psa/admin/sbin/packagemng --set-dirty-flag
OR
Go to the Plesk > Tools & Settings > Server Components page and click the Refresh button to update information about quota.Note: A separate component will not appear, but Plesk components cache will be updated to include new information and isHardQuotaEnabled will be true in psa database:
# plesk db "select * from ServiceNodeEnvironment where name='isHardQuotaEnabled'"
+---------------+---------+--------------------+-------+
| serviceNodeId | section | name | value |
+---------------+---------+--------------------+-------+
| 1 | os | isHardQuotaEnabled | true |
+---------------+---------+--------------------+-------+
Comments
4 comments
@Ahmed, make sure that quota is enabled on drive in its properties on 'Quota' tab
# /usr/local/psa/admin/sbin/usermng --isquotable
returned "1"
using the workaround for #PPPM-3826 as mentioned here fixed the issue: https://support.plesk.com/hc/en-us/articles/213947125-Hard-quota-on-disk-space-is-not-manageable (just mentioning it here so there is at least some sort of reference ;) )
Hello , I have the exact same issue but Im working on windows server 2012
how can I fix it on windows ?
@Vitaly Zhidkov Thank you it worked :)
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