Unable to import site from Sitebuilder 4.5 to Web Presence Builder

Created:

2016-11-16 12:39:52 UTC

Modified:

2017-04-24 12:16:01 UTC

0

Was this article helpful?


Have more questions?

Submit a request

Unable to import site from Sitebuilder 4.5 to Web Presence Builder

Applicable to:

  • Web Presence Builder 11.0 for Linux
  • Plesk 11.5 for Linux

Symptoms

An attempt to import site from Sitebuilder 4.5 fails with the following error:

The specified URL is not valid. Invalid url given.

Cause

There is encrypted data in the vhost directory, that can not be parsed.

Resolution

  1. Check the domain's error log (for example, /var/www/vhosts/domain.com/logs/error_log ) for errors like the following:

    [Wed Jul 30 23:16:33 2014] [error] [client 91.204.25.44] PHP Deprecated:  Function set_magic_quotes_runtime() is deprecated in /var/www/vhosts/domain.com/httpdocs/init.php on line 44, referer: http://domain.com/page8.php
    [Wed Jul 30 23:16:34 2014] [error] [client 91.204.25.44] PHP Deprecated: Function set_magic_quotes_runtime() is deprecated in /var/www/vhosts/domain.com/httpdocs/init.php on line 44, referer: http://domain.com/page3.php?category=0&image=1&view=preview
  2. Move the problematic file to some temporary directory:

    # mv /var/www/vhosts/domain.com/httpdocs/init.php /tmp/
  3. Repeat the import operation.

  4. Move the file back to keep website consistency.

Have more questions? Submit a request
Please sign in to leave a comment.